Welcome to Linux Knowledge Base and Tutorial
"The place where you learn linux"
Apress - Books for Professionals by Professionals

 Create an AccountHome | Submit News | Your Account  

Tutorial Menu
Linux Tutorial Home
Table of Contents

· Introduction to Operating Systems
· Linux Basics
· Working with the System
· Shells and Utilities
· Editing Files
· Basic Administration
· The Operating System
· The X Windowing System
· The Computer Itself
· Networking
· System Monitoring
· Solving Problems
· Security
· Installing and Upgrading
· Linux and Windows

Glossary
MoreInfo
Man Pages
Linux Topics
Test Your Knowledge

Site Menu
Site Map
FAQ
Copyright Info
Terms of Use
Privacy Info
Disclaimer
WorkBoard
Thanks
Donations
Advertising
Masthead / Impressum
Your Account

Communication
Feedback
Forums
Private Messages
Recommend Us
Surveys

Features
HOWTOs
News
News Archive
Submit News
Topics
User Articles
Web Links

Google
Google


The Web
linux-tutorial.info

Who's Online
There are currently, 190 guest(s) and 1 member(s) that are online.

You are an Anonymous user. You can register for free by clicking here

  
Linux Knowledge Base and Tutorial: Forums



Linux Tutorial :: View topic - FTP Problem with Redhat 9
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

FTP Problem with Redhat 9

 
Post new topic   Reply to topic    Linux Tutorial Forum Index -> Software
View previous topic :: View next topic  
Author Message
kelton
Newbie


Joined: Nov 12, 2003
Posts: 2

PostPosted: Tue Apr 06, 2004 2:54 pm    Post subject: FTP Problem with Redhat 9 Reply with quote

I am trying to get my FTP server working with my Redhat 9 install. This is a basic install, using everything that came with the CDs.


I have checked the service is on, and try to log in from the same machine and get the following:

[shadow@Boothby etc]$ ftp localhost
Connected to Boothby.
220 Boothby FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets cached
Name (localhost:shadow): shadow
530 Must perform authentication before identifying USER.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>



Any help in telling me what is wrong, and how to fix would be apreciated.
Back to top
View user's profile Send private message
Guest






PostPosted: Fri Apr 09, 2004 6:34 pm    Post subject: Reply with quote

I have never set up FTP using the GSSAPI or kerberos. Have you tried without the kerberos? I did a quick search on google and apparently it is not as easy as one would think (based on the number of people with the same problem).
Back to top
Richie086
Beginner


Joined: Feb 07, 2005
Posts: 20
Location: USA

PostPosted: Fri Feb 11, 2005 12:39 pm    Post subject: Reply with quote

[quote][shadow@Boothby etc]$ ftp localhost
Connected to Boothby.
220 Boothby FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
[/quote]

what ftp server deamon are u actually using?

vsftpd should work pretty much out of the box... if not just edit your /etc/vsftpd/vsftpd.conf file.. also be sure to check your /etc/vsftpd.users (not %100 sure about the file name).. Depending on what kinda options u have selected in your vsftpd.conf file, the server will either allow or deny users listed in that file (or only allow or deny users in that file, it all depends on what u have setup in your .conf file)..

after editing, just restart ur vsftpd deamon

$ service vsftpd restart

or

$ /etc/rc.d/init.d/vsftpd restart

the 2nd way is a bit harder to commit to memory tho Smile

richie
Back to top
View user's profile Send private message Visit poster's website
atsol
Guest





PostPosted: Wed Feb 16, 2005 9:58 pm    Post subject: Solution??? Reply with quote

This same problem has been dropped on my lap....our unix admin just quit. I can ftp FROM host A to host B, but I cannot ftp from host B to host A (I get the following error:

220 expdb01 FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets cached

I started the vsftpd daemon, but I get the same results. Also, I am suprised to see that the daemon starts properly (receive OK), yet when you grep for the process, nothing exists.

I'm pretty green when it comes to ftp configuration (especially with RHEL 3.0), so any help would be greatly appreciated.
Back to top
Guest






PostPosted: Wed Mar 16, 2005 5:09 pm    Post subject: Re: FTP Problem with Redhat 9 Reply with quote

[quote="kelton"]I am trying to get my FTP server working with my Redhat 9 install. This is a basic install, using everything that came with the CDs.


I have checked the service is on, and try to log in from the same machine and get the following:

[shadow@Boothby etc]$ ftp localhost
Connected to Boothby.
220 Boothby FTP server (Version 5.60) ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets cached
Name (localhost:shadow): shadow
530 Must perform authentication before identifying USER.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>



Any help in telling me what is wrong, and how to fix would be apreciated.[/quote]
Back to top
Guest






PostPosted: Mon Mar 28, 2005 9:01 pm    Post subject: Reply with quote

If you are using gssftp

open this file:

/etc/xinit.d/gssftp

locate this line:

server_args = -l -a

remove the -a

that is it
Back to top
Guest






PostPosted: Thu Mar 31, 2005 2:45 am    Post subject: Reply with quote

Thanks a lot. I had the same problem and i removed the '-a' from the /etc/xinet.d/gssftp file, restarted xinetd (not sure if I needed to do this) and it worked.

Thanks a lot!
Back to top
th1alb
Guest





PostPosted: Fri Jun 17, 2005 5:53 pm    Post subject: Reply with quote

i have been trying to get my ftp to run for an hour now.
thought about wu-ftp but too complicated!
im a noob


i found this thread and tried that (remove -a)
and it freakin works

thank you so much, i love forums
Back to top
guest
Guest





PostPosted: Mon Jul 11, 2005 11:23 pm    Post subject: removing -a work great !!! Reply with quote

[b]thanks you ![/b]
Back to top
guest
Guest





PostPosted: Thu Aug 25, 2005 4:10 pm    Post subject: using gssftp Reply with quote

I can't seem to find out how to change the banner with gssftp?

I can find out for vsftp, and wu, but not gssftp.

tz
Back to top
ajchai
Guest





PostPosted: Wed Sep 21, 2005 5:32 am    Post subject: Thanks Reply with quote

Hi All, Thanks for the help.

It's WORK...............yeah
Back to top
natalie_chong78
Guest





PostPosted: Wed Nov 09, 2005 7:03 am    Post subject: Reply with quote

[quote="jimmo."]If you are using gssftp

open this file:

/etc/xinit.d/gssftp

locate this line:

server_args = -l -a

remove the -a

that is it[/quote]


Thanks a lot ..!!!! it's work.. Thank you thank you....thank you
Back to top
natalie_chong78
Guest





PostPosted: Wed Nov 09, 2005 7:04 am    Post subject: Reply with quote

[quote="jimmo."]If you are using gssftp

open this file:

/etc/xinit.d/gssftp

locate this line:

server_args = -l -a

remove the -a

that is it[/quote]


Thanks a lot ..!!!! it's work.. Thank you thank you....thank you
Back to top
viplav
Newbie


Joined: Dec 06, 2005
Posts: 1

PostPosted: Tue Dec 06, 2005 8:58 am    Post subject: gssftp Reply with quote

changing the option by removing -a worked.. thank you very much.. but I would like to know how ? If someone can find more infor about this option please quote it.. that will be really great !
Back to top
View user's profile Send private message
tripwire45
Wizard


Joined: Jul 7, 2003
Posts: 1270
Location: Boise, ID, USA

PostPosted: Tue Dec 06, 2005 5:08 pm    Post subject: Re: gssftp Reply with quote

[quote="viplav"]changing the option by removing -a worked.. thank you very much.. but I would like to know how ? If someone can find more infor about this option please quote it.. that will be really great ![/quote]Not sure if this is correct but it seems to fit the bill. If I'm reading this article correctly, the -a option requires users to logon using strong encryption. Removing this option takes away the requirement, allowing users to make the connection. Here's the link:

https://www.redhat.com/archives/fedora-selinux-list/2005-June/msg00285.html
_________________
[img]http://www.debian.org/logos/button-2.gif[/img]
Back to top
View user's profile Send private message Visit poster's website
baobaobeibei14
Newbie


Joined: Nov 19, 2010
Posts: 3

PostPosted: Fri Nov 19, 2010 2:00 am    Post subject: Reply with quote

REMOVED SPAM
_________________
baobaobeibei14@gmail.com
Back to top
View user's profile Send private message
ClairRichmond12
Newbie


Joined: May 21, 2014
Posts: 1

PostPosted: Thu May 22, 2014 8:12 am    Post subject: Let me no the answer too Reply with quote

Let me no the answer too. thank you
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Linux Tutorial Forum Index -> Software All times are GMT
Page 1 of 1

 

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001-2007 phpBB Group
  
Show your Support for the Linux Tutorial

Purchase one of the products from our new online shop. For each product you purchase, the Linux Tutorial gets a portion of the proceeds to help keep us going.


Login
Nickname

Password

Security Code
Security Code
Type Security Code


Don't have an account yet? You can create one. As a registered user you have some advantages like theme manager, comments configuration and post comments with your name.

Help if you can!


Amazon Wish List

Did You Know?
You can choose larger fonts by selecting a different themes.


Friends



Tell a Friend About Us

Bookmark and Share



Web site powered by PHP-Nuke

Is this information useful? At the very least you can help by spreading the word to your favorite newsgroups, mailing lists and forums.
All logos and trademarks in this site are property of their respective owner. The comments are property of their posters. Articles are the property of their respective owners. Unless otherwise stated in the body of the article, article content (C) 1994-2013 by James Mohr. All rights reserved. The stylized page/paper, as well as the terms "The Linux Tutorial", "The Linux Server Tutorial", "The Linux Knowledge Base and Tutorial" and "The place where you learn Linux" are service marks of James Mohr. All rights reserved.
The Linux Knowledge Base and Tutorial may contain links to sites on the Internet, which are owned and operated by third parties. The Linux Tutorial is not responsible for the content of any such third-party site. By viewing/utilizing this web site, you have agreed to our disclaimer, terms of use and privacy policy. Use of automated download software ("harvesters") such as wget, httrack, etc. causes the site to quickly exceed its bandwidth limitation and are therefore expressly prohibited. For more details on this, take a look here

PHP-Nuke Copyright © 2004 by Francisco Burzi. This is free software, and you may redistribute it under the GPL. PHP-Nuke comes with absolutely no warranty, for details, see the license.
Page Generation: 0.11 Seconds